self

A collection of 5 posts

解决 Ghost CLI 升级问题

2017年7月尾的时候 Ghost 博客平台发布了 CLI 安装、升级博客更容易了。 0.x 版本的没法直接升级,只能导出原来的博客文章,安装新的 Ghost 1.x 后再导入原本的文章。 但这些都不是今天要说的话题,最近怎么升级都遇到什么 DB migrate 失败,what the。。。 官方解答都没遇到这些问题呢,黑人问号❓找了很久都没答案。。。博客要永远挂了吗? 终极答案 试了用 Yarn 安装 Ghost-CLI 解决了这个问题。 sudo

Oct 5, 2014

開啓 SSL 今天開始博客開始使用 SSL 協議。由於是 Cloudflare 免費提供的,有一個缺點,就是不支持 Windows XP 的 Internet Explorer 用戶。HTTPS 有沒有提升搜索排名,我就不清楚了。但是,保證遊覽安全是肯定的。 博客評論系統暫停 由於 Ghost 的 API 改動,評論系統需求一些公用的 API 沒法使用,我也不想去黑 core 文件,

记录搭建 Ghost 博客。基于 Node.js 再配合 Nginx 代理。资料库可选 SQLite 或者 MySQL。后台使用实时运行的 Markdown 编辑器。 系统要求 Node.js v0.10+ 安装 Node.js 很简单,到官方网站点击那个很大的 Install 按钮。 下载 官方网站 Ghost.org GitHub